Чтение таблицы MySQL в таблицу значений

Публикация № 1118298

Обработки - Универсальные обработки

MySQL обработка чтение таблица запрос ODBC Таблица Значений База sql

3
Отчет для чтения через ODBC данных любой Таблицы базы MySQL в Таблицу Значений, а также вывод этот таблицы на форму. Для этого есть отдельная функция. Также используется чтение системной таблицы INFORMATION_SCHEMA для получения списка Таблиц в базе данных, или получения Колонок в Таблице. Проверялось на платформе 8.3.13.1513.

Пример чтения любой таблицы из баз MySQL через ODBC, а также выгрузка результата в ТЗ и вывода на форму.

Для чтения требуется установка коннектора https://dev.mysql.com/downloads/connector/odbc/5.1.html

Можно использовать, дополнительные параметры к запросу, типа условия по дате и т.п. Все настройки прямо для форме для наглядности. 

Для использования в своих проектах, возможно, потребуется что-то доработать.

 

//Пример функции чтения в ТЗ
&НаКлиенте
Функция ПрочитатьТаблицуMySQL(АдресСервера,НомерПорта,ИмяБД,Пользователь,Пароль,ИмяТаблицы,СписокКолонок,ПрямойЗапрос="",Ошибка="",ДопПараметр="")    
    Колонки = СтрокуВМассив(СписокКолонок,","); //Тут список колонок преобразуем в массив
    ТекТЗ = СоздатьТЗ(Колонки); //Создаем ТЗ и добавляем колонки куда будем выгружать
    
    //Само чтение Таблицы из MySQL
    Connection = Новый COMОбъект("ADODB.Connection");    
    Попытка      
        Connection.Open("Driver={MySQL ODBC 5.1 Driver};Server="+СокрЛП(АдресСервера)+";Port="+НомерПорта+";Database="+СокрЛП(ИмяБД)+";User="+СокрЛП(Пользователь)+";Password="+Пароль+";Option=3");        
    Исключение
        Ошибка = "Ошибка подключения - " + ОписаниеОшибки();  
        Возврат ТекТЗ;
    КонецПопытки;    
        
    RS = Новый COMОбъект("ADODB.RecordSet");
    RS.ActiveConnection = Connection;
    Если ЗначениеЗаполнено(ПрямойЗапрос) Тогда
        ТекстЗапросаMySQL = ПрямойЗапрос;
    Иначе    
        ТекстЗапросаMySQL = "SELECT "+СписокКолонок+" FROM "+ИмяТаблицы+" "+ДопПараметр; //+ " WHERE " +ИмяТаблицы+ ".Type = 'Sale';" ;
    КонецЕсли;        
    
    //Сообщить(ТекстЗапросаMySQL);
    
    RS.Open(ТекстЗапросаMySQL);
    RS.MoveFirst(); 
    Пока RS.EOF()=0 Цикл      
        НовСтрока = ТекТЗ.Добавить();
        Для Каждого ТекКолонка из Колонки Цикл
            НовСтрока[ТекКолонка] = RS.Fields(ТекКолонка).Value; //Сообщить(ТекКолонка+"="+НовСтрока[ТекКолонка]);
        КонецЦикла;               
        RS.MoveNext();    
    КонецЦикла; 
    RS.Close();    
      Connection.Close(); 
    Возврат ТекТЗ;
КонецФункции


Функция СоздатьТЗ(Колонки=Неопределено)
	ТекТЗ = Новый ТаблицаЗначений;		
	Если ЗначениеЗаполнено(Колонки) Тогда
		Для Каждого ТекКолонка из Колонки Цикл
			ТекТЗ.Колонки.Добавить(ТекКолонка);
		КонецЦикла;	
	КонецЕсли;
	Возврат ТекТЗ; 
КонецФункции

Функция СтрокуВМассив(Знач Стр, Разделитель=",")
	МассивСтрок = Новый Массив();
	ДлинаРазделителя = СтрДлина(Разделитель);
	Пока 1=1 Цикл
		Поз = Найти(Стр,Разделитель);
		Если Поз=0 Тогда
			МассивСтрок.Добавить(Стр);
			Возврат МассивСтрок;
		КонецЕсли;
		МассивСтрок.Добавить(Лев(Стр,Поз-1));
		Стр = Сред(Стр,Поз+ДлинаРазделителя);
	КонецЦикла;	
	Возврат МассивСтрок;
КонецФункции

 

3

Скачать файлы

Наименование Файл Версия Размер
Чтение таблицы MySQL в Таблицу Значений:
.erf 9,72Kb
05.09.19
3
.erf 1.0 9,72Kb 3

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение